Mail Service Incident

Incident Report for ValuePRO

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 15:09 AEST

Investigating

We are currently investigating an issue that is impacting mail delivery from ValuePRO.
Posted Mar 09, 2026 - 09:20 AEST
This incident affected: AU Region, NZ Region, EU Region, UK Region, and International Regions.